Unity2018.3.0f2での使用について

main BBS フォーラム システム・仕様系Q&A Unity2018.3.0f2での使用について

このトピックには4件の返信が含まれ、2人の参加者がいます。5 ヶ月、 3 週間前 emote_ofc さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #13373 返信

    sadato

    お世話になっております。

    先日リリースされた Unity2018.3.0f2 で Scripting Backend に il2cpp を設定すると、Android/iOS 実機で表示されないという問題が起きております。
    monoに変更すると表示されます。

    こちら、il2cppで表示する方法はございますでしょうか。
    ご確認の程よろしくお願い致します。

    #13374 返信

    emote_ofc
    キーマスター

    E-moteオフィシャルです!

    ご質問をいただきありがとうございます。
    また、ご不便をおかけしており申し訳ございません。

    書き込みをいただきました現象を確認いたしました。
    検証を始めますので、恐れ入りますが今しばらくお待ちいただけますと幸いです。

    よろしくお願いいたします。

    #13379 返信

    emote_ofc
    キーマスター

    E-moteオフィシャルです!

    問題の原因がわかりました。
    Unityの特定のバージョンに存在するIL2CPPのバグの影響でした。

    Emote側のコードで対応可能なので近日中に修正版をリリースいたします。
    修正点はわずかなので、お手元のコードを修正していただくことでも対処可能です。

    以下、修正点を示しておきます。

    Assets/EmotePlayer/Scripts/EmotePlayer.cs の 74行目と77行目

    const CharSet importCharSet = CharSet.Auto;

    const CharSet importCharSet = CharSet.Ansi;

    と書き換えます。

    お手数をおかけしてしまい申し訳ございません。
    リリースをお待ちいただけますと幸いです。

    今後とも、E-mote・えもふりならびに有限会社エムツーをよろしくお願いいたします。

    #13382 返信

    sadato

    お世話になっております。

    検証、対処法のご共有ありがとうございます。
    リリースをお待ちしております。

    ご対応ありがとうございました。

    #13389 返信

    emote_ofc
    キーマスター

    E-moteオフィシャルです!

    先日、修正版をリリースさせていただきました。
    最新版のエディタで試していただけますでしょうか。

    どうぞよろしくお願いいたします。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
返信先: Unity2018.3.0f2での使用について
あなたの情報:





<a href="" title="" rel="" target=""> <blockquote cite=""> <code> <pre> <em> <strong> <del datetime=""> <ul> <ol start=""> <li> <img src="" border="" alt="" height="" width="">